RulesetInsertOptions Interface
Options for RulesetEmbedder.insertRuleset operation.
Properties
Name | Type | Description | |
---|---|---|---|
onEntityInsert | undefined | InsertCallbacks | Callbacks that will be called before and after Entity is inserted |
|
onEntityUpdate | undefined | UpdateCallbacks | Callbacks that will be called before and after Entity updates |
|
replaceVersions | "all" | "all-lower" | "exact" | Which existing versions of rulesets with same id should be replaced when we insert a new one: | |
skip | "never" | "same-id" | "same-id-and-version-eq" | "same-id-and-version-gte" | When should insertion be skipped: |
Defined in
Last Updated: 20 June, 2023