DrawingNavigationAidProps Interface
Properties for the DrawingNavigationAid component
Extends
Methods
Name | Description | |
---|---|---|
onAnimationEnd(): void Optional |
Properties
Name | Type | Description | |
---|---|---|---|
iModelConnection | IModelConnection | ||
viewport | undefined | Viewport |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
- ui/imodel-components-react/src/imodel-components-react/navigationaids/DrawingNavigationAid.tsx Line 35
Last Updated: 20 June, 2023