LineWeightSwatchProps Interface
Properties for the LineWeightSwatch React component
Extends
Methods
Name |
Description |
|
onClick(): void Optional |
function to run when user selects a line weight swatch |
|
Properties
Name |
Type |
Description |
|
colorDef |
undefined | ColorDef |
color specification |
|
disabled |
undefined | boolean |
Disabled or not |
|
hideLabel |
undefined | boolean |
hide the weight label |
|
readonly |
undefined | boolean |
Readonly or not |
|
weight |
number |
color specification |
|
Inherited properties
Name |
Type |
Inherited from |
Description |
itemId |
undefined | string |
CommonProps |
Optional unique identifier for item. |
Defined in
Last Updated:
20 June, 2023