ColorSwatchProps Interface
Beta
Properties for the ColorSwatch React component
Extends
- ButtonHTMLAttributes<HTMLButtonElement>
- CommonProps
Properties
Name | Type | Description | |
---|---|---|---|
colorDef | ColorDef | color specification | |
onColorPick | undefined | (color: ColorDef, e: MouseEvent<Element, MouseEvent>) => void | ||
round | undefined | boolean | Show swatches as squares unless round is set to true |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
Defined in
Last Updated: 20 June, 2023