ColorPickerProps Interface
Beta
Properties for the ColorPickerButton React component
Extends
- ButtonHTMLAttributes<HTMLButtonElement>
- CommonProps
Properties
Name | Type | Description | |
---|---|---|---|
colorDefs | undefined | ColorDef[] | Available colors | |
disabled | undefined | boolean | Disabled or not | |
dropDownTitle | undefined | string | Title to show at top of DropDown | |
initialColor | ColorDef | Active color | |
numColumns | undefined | number | Number of columns | |
onColorPick | undefined | (color: ColorDef) => void | ||
readonly | undefined | boolean | Readonly or not | |
ref | undefined | Ref<HTMLButtonElement> | Provides ability to return reference to HTMLButtonElement | |
round | undefined | boolean | Show swatches as squares unless round is set to true | |
showCaret | undefined | boolean | If true show up/down caret next to color |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
Defined in
Last Updated: 20 June, 2023