SectionGraphicsConfig Interface
Configures how 2d graphics are displayed by a HyperModelingDecorator when hypermodeling is active. This configuration is used primarily for debugging, and applies globally to section graphics associated with all HyperModelingDecorators.
see HyperModeling.initialize to set this configuration at package initialization.
see HyperModeling.updateConfiguration or HyperModeling.replaceConfiguration to change this configuration after package initialization.
see HyperModelingConfig.
Properties
Name | Type | Description | |
---|---|---|---|
debugClipVolumes Readonly | undefined | boolean | If true, clip volumes for 2d graphics are displayed as shapes. | |
hideSectionGraphics Readonly | undefined | boolean | If true, SectionDrawing graphics will not be displayed. | |
hideSheetAnnotations Readonly | undefined | boolean | If true, Sheet annotation graphics will not be displayed. | |
ignoreClip Readonly | undefined | boolean | If true, 2d graphics will not be clipped. |
Defined in
Last Updated: 20 June, 2023