then Method
Attaches callbacks for the resolution and/or rejection of the Promise.
then<TResult1, TResult2>(onfulfilled?: | (value: T) => TResult1 | PromiseLike<TResult1>, onrejected?: | (reason: any) => TResult2 | PromiseLike<TResult2>): Promise<TResult1 | TResult2>
Returns - Promise<TResult1 | TResult2>
A Promise for the completion of which ever callback is executed.
Defined in
Last Updated: 20 June, 2023