RelationshipClassProps Interface
Beta
Extends
Properties
Name | Type | Description | |
---|---|---|---|
source Readonly | RelationshipConstraintProps | ||
strength Readonly | string | ||
strengthDirection Readonly | string | ||
target Readonly | RelationshipConstraintProps |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
$schema Readonly | undefined | string | ClassProps | |
baseClass Readonly | undefined | string | ClassProps | |
customAttributes Readonly | undefined | { T }[] | ClassProps | |
description Readonly | undefined | string | ClassProps | |
label Readonly | undefined | string | ClassProps | |
modifier Readonly | undefined | string | ClassProps | |
name Readonly | undefined | string | ClassProps | |
properties Readonly | undefined | AnyPropertyProps[] | ClassProps | |
schema Readonly | undefined | string | ClassProps | |
schemaItemType Readonly | undefined | string | ClassProps | |
schemaVersion Readonly | undefined | string | ClassProps |
Defined in
Last Updated: 20 June, 2023