getSchemaSync Method
Attempts to get a schema from the locater. Yields undefined if no matching schema is found. For schemas that may have references, construct and call through a SchemaContext instead.
getSchemaSync<T extends Schema<T>>(schemaKey: SchemaKey, matchType: SchemaMatchType, context?: SchemaContext): undefined | T
Parameter | Type | Description |
---|---|---|
schemaKey | SchemaKey | key to look up |
matchType | SchemaMatchType | how to match key against candidate schemas |
context | SchemaContext | optional context for loading schema references |
Returns - undefined | T
Last Updated: 20 June, 2023