constructor Method
Construct a new TemplateModelCloner
TemplateModelCloner(sourceDb: IModelDb, targetDb: IModelDb = sourceDb): TemplateModelCloner
note The expectation is that the template definitions are within the same iModel where instances will be placed.
Parameter | Type | Description |
---|---|---|
sourceDb | IModelDb | The source IModelDb that contains the templates to clone |
targetDb | IModelDb | Optionally specify the target IModelDb where the cloned template will be inserted. Typically this is left unspecified, and the default is to use the sourceDb as the target |
Returns - TemplateModelCloner
Defined in
- transformer/src/IModelTransformer.ts Line 1547
Last Updated: 20 June, 2023