processModel Method
Cause the model container, contents, and sub-models to be exported from the source iModel and imported into the target iModel.
processModel(sourceModeledElementId: string): Promise<void>
note This method is called from IModelTransformer.processChanges and IModelTransformer.processAll, so it only needs to be called directly when processing a subset of an iModel.
Parameter | Type | Description |
---|---|---|
sourceModeledElementId | string | Import this Model from the source IModelDb. |
Returns - Promise<void>
Defined in
- transformer/src/IModelTransformer.ts Line 890
Last Updated: 20 June, 2023