processElement Method
Cause the specified Element and its child Elements (if applicable) to be exported from the source iModel and imported into the target iModel.
processElement(sourceElementId: string): Promise<void>
note This method is called from IModelTransformer.processChanges and IModelTransformer.processAll, so it only needs to be called directly when processing a subset of an iModel.
Parameter | Type | Description |
---|---|---|
sourceElementId | string | Identifies the Element from the source iModel to import. |
Returns - Promise<void>
Defined in
- transformer/src/IModelTransformer.ts Line 694
Last Updated: 20 June, 2023