onInsertRelationship MethodProtected
Create a new Relationship from the specified RelationshipProps and insert it into the target iModel.
onInsertRelationship(relationshipProps: RelationshipProps): string
note A subclass may override this method to customize insert behavior but should call super.onInsertRelationship
.
Parameter | Type | Description |
---|---|---|
relationshipProps | RelationshipProps |
Returns - string
The instance Id of the newly inserted relationship.
Defined in
- transformer/src/IModelImporter.ts Line 456
Last Updated: 20 June, 2023