shouldExportElement Method
Returns true if the specified element should be exported. This considers the standard IModelExporter exclusion rules plus calls IModelExportHandler.shouldExportElement for any custom exclusion rules.
shouldExportElement(element: Element): boolean
note This method is called from within IModelExporter.exportChanges and IModelExporter.exportAll, so usually does not need to be called directly.
Parameter | Type | Description |
---|---|---|
element | Element |
Returns - boolean
Defined in
- transformer/src/IModelExporter.ts Line 560
Last Updated: 20 June, 2023