getIconData MethodStatic
Returns an icon definition that can be stored in an abstract item definition. If the iconSpec specifies a ReactNode then the react data is stored in the internalData map and the key to the react data is returned.
getIconData(iconSpec: IconSpec, internalData?: Map<string, any>): string | ConditionalStringValue
Parameter | Type | Description |
---|---|---|
iconSpec | IconSpec | any supported variations of how an icon can be defined in an abstract item or IconProps. |
internalData | Map<string, any> | a map supplied by the caller to store away react element if React.ReactNode |
Returns - string | ConditionalStringValue
Defined in
Last Updated: 20 June, 2023