constructor Method

Constructor

UiStateEntry<T>(settingNamespace: string, settingName: string, getValue: () => T, applyValue?: (v: T) => void, defaultValue?: T): UiStateEntry<T>

Parameter Type Description
settingNamespace string Namespace for the setting, passed to UiStateStorage.
settingName string Name for the setting, passed to UiStateStorage.
getValue () => T Function for getting the value from the application.
applyValue (v: T) => void Function for applying the setting value to the application.
defaultValue T Optional default value if not already stored.

Returns - UiStateEntry<T>

Defined in

Last Updated: 20 June, 2023