TooltipProps Interface
Deprecated in 3.0. Use TooltipProps in itwinui-react instead
Beta
Properties for the Tooltip component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
children | undefined | ReactNode | Tooltip content. | |
placement | undefined | TooltipPlacement | Preferred tooltip placement. | |
target | undefined | HTMLElement | Target element of a tooltip. | |
visible | undefined | boolean | Allows to control tooltip visibility state. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023