Deprecated in 3.0. Use SplitButtonProps in itwinui-react instead
Properties for SplitButton component
Extends
Methods
Name |
Description |
|
onClick(event: any): any Optional |
Listens for click events on button area |
|
onExecute(): any Optional |
Listens for execute on button area |
|
Properties
Name |
Type |
Description |
|
buttonType |
undefined | ButtonType |
4 styles to tweak the content of the button |
|
drawBorder |
undefined | boolean |
Indicates whether to draw a border around the button |
|
icon |
undefined | IconSpec |
Specifies icon for Splitbutton component |
|
label |
ReactNode |
Label to display in click area. |
|
undefined | RelativePosition |
Direction relative to the button to which the popup is expanded (defaults to Bottom) |
|
toolTip |
undefined | string |
ToolTip text |
|
Inherited properties
Defined in
Last Updated:
20 June, 2023