RadialButtonProps Interface
Properties for RadialButton component
Extends
Methods
Name | Description | |
---|---|---|
onSelect(e: any): any Optional | listens to any onClick event, or any select event, which can be triggered by the select() method. |
Properties
Name | Type | Description | |
---|---|---|---|
icon | undefined | IconSpec | which icon to display in on the menu button | |
labelRotate | undefined | boolean | Whether label is rotated to radial menu. | |
selected | undefined | boolean | Whether item is highlighted |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023