ProgressBarProps Interface
Deprecated in 3.0. Use ProgressLinearProps in itwinui-react instead.
Beta
Properties for ProgressBar component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
barHeight | undefined | number | Height (in pixels) of the progress bar. | |
indeterminate | undefined | boolean | Indicates whether the progress bar is determinate showing a percentage or indeterminate continuously animating. | |
labelLeft | undefined | string | One of two possible labels. | |
labelRight | undefined | string | One of two possible labels. | |
percent | undefined | number | Percent for determinate progress bar. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023