FormProps Interface
Properties that define Form including the callback to be called when the Submit button is pressed.
Methods
Name | Description | |
---|---|---|
handleFormSubmit(values: FieldValues): Promise<void> | Required async callback the processes the Form data and throws and Error if the data cannot be processed. |
Properties
Name | Type | Description | |
---|---|---|---|
fields | FieldDefinitions | Definition used to create each Field in the Form. | |
submitButtonLabel | undefined | string | Optional label which will override default Submit button label. |
Defined in
Last Updated: 20 June, 2023