ExpandableBlockProps Interface
Deprecated in 3.0. Use ExpandableBlockProps from itwinui-react instead
Properties for the ExpandableBlock React component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
caption | undefined | string | Additional text displayed in the block below the label and in a smaller font size | |
isExpanded | boolean | Indicates whether the ExpandableBlock is expanded | |
onClick | MouseEventHandler<HTMLDivElement> | Callback function for click event | |
onKeyDown | undefined | KeyboardEventHandler<HTMLDivElement> | Callback function for key down event | |
onKeyPress | undefined | KeyboardEventHandler<HTMLDivElement> | Callback function for key press event | |
title | string | Element | Label | |
tooltip | undefined | string | Custom tooltip for the component. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 20 June, 2023