MessageBoxProps Interface
Properties for the MessageBox component
Extends
Methods
Name |
Description |
|
onClose(): void Optional |
onClick event for X button for dialog |
|
onEscape(): void Optional |
'keyup' event for key |
|
Properties
Name |
Type |
Description |
|
buttonCluster |
DialogButtonDef[] |
List of DialogButtonDef objects specifying buttons and associated onClick events |
|
contentClassName |
undefined | string |
Custom CSS class name for the content |
|
contentStyle |
undefined | CSSProperties |
Custom CSS Style for the content |
|
height |
string | number |
initial height of dialog. |
|
minHeight |
undefined | number |
minimum height that the dialog may be resized to. |
|
minWidth |
undefined | number |
minimum width that the dialog may be resized to. |
|
modal |
undefined | boolean |
Whether to show background overlay. |
|
opened |
boolean |
whether to show dialog or not |
|
severity |
MessageSeverity |
Severity of MessageBox |
|
title |
string | Element |
Title to show in title bar of dialog |
|
width |
string | number |
initial width of dialog. |
|
Inherited properties
Defined in
Last Updated:
20 June, 2023