CheckboxProps Interface
Deprecated in 3.0. Use CheckboxProps in itwinui-react instead
Properties for Checkbox React component
Extends
- Omit<React.InputHTMLAttributes<HTMLInputElement>, "type" | "onClick" | "onBlur">
- CommonProps
Methods
Name |
Description |
|
onBlur(e: FocusEvent<Element, Element>): void Optional |
Event called when checkbox loses focus. |
|
onClick(e: MouseEvent<Element, MouseEvent>): void Optional |
Event called when checkbox is clicked on. |
|
Properties
Name |
Type |
Description |
|
indeterminate |
undefined | boolean |
Indicates checkbox is in an Indeterminate or Partial state, regardless of the checked state |
|
inputClassName |
undefined | string |
Custom CSS class name for the checkbox input element |
|
inputRef |
undefined | Ref<HTMLInputElement> |
Provides ability to return reference to HTMLInputElement |
|
inputStyle |
undefined | CSSProperties |
Custom CSS Style for the checkbox input element |
|
label |
undefined | string |
Text that will be shown next to the checkbox. |
|
labelClassName |
undefined | string |
Custom CSS class name for the label element |
|
labelStyle |
undefined | CSSProperties |
Custom CSS Style for the label element |
|
setFocus |
undefined | boolean |
Indicates whether the checkbox should set focus |
|
status |
undefined | InputStatus |
Input status like: "Success", "Warning" or "Error" |
|
Inherited properties
Name |
Type |
Inherited from |
Description |
itemId |
undefined | string |
CommonProps |
Optional unique identifier for item. |
Defined in
Last Updated:
20 June, 2023