ButtonProps Interface
Deprecated in 3.0. Use ButtonProps from itwinui-react instead
Properties for Button component
Extends
- ButtonHTMLAttributes<HTMLButtonElement>
- CommonProps
Properties
Name | Type | Description | |
---|---|---|---|
buttonType | undefined | ButtonType | 4 styles to tweak the content of the button | |
id | undefined | string | Allow ID to be passed to Button | |
onClick | undefined | (event: MouseEvent<HTMLButtonElement, MouseEvent>) => void | ||
size | undefined | ButtonSize | Default and large sizes |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
Defined in
Last Updated: 20 June, 2023