CustomFormatProps Interface
Beta
This interface is used when supporting Custom Formatters that need more than the standard set of properties.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
custom Readonly | any |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
composite Readonly | undefined | { includeZero?: boolean, spacer?: string, units: { label?: string, name: string }[] } | FormatProps | |
decimalSeparator Readonly | undefined | string | FormatProps | |
formatTraits Readonly | string | string[] | FormatProps | |
minWidth Readonly | undefined | number | FormatProps | |
precision Readonly | undefined | number | FormatProps | |
roundFactor Readonly | undefined | number | FormatProps | |
scientificType Readonly | undefined | string | FormatProps | |
showSignOption Readonly | undefined | string | FormatProps | |
stationOffsetSize Readonly | undefined | number | FormatProps | |
stationSeparator Readonly | undefined | string | FormatProps | |
thousandSeparator Readonly | undefined | string | FormatProps | |
type Readonly | string | FormatProps | |
uomSeparator Readonly | undefined | string | FormatProps |
Defined in
Last Updated: 20 June, 2023