CloneOptions Interface
Beta
CloneOptions that define modifications that can be made during the cloning of a Format.
Properties
Name | Type | Description | |
---|---|---|---|
precision | DecimalPrecision | FractionalPrecision | allows precision to be set, this will throw if value is not valid for FormatType | |
primaryUnit | undefined | CloneUnit | allows primary unit and label to be specified | |
showOnlyPrimaryUnit | undefined | boolean | allows composite formats to be converted to only show primary unit | |
traits | undefined | FormatTraits | allow format traits to be set | |
type | undefined | FormatType | allows new FormatType to be specified |
Defined in
Last Updated: 20 June, 2023