createFaceLoopFromCoordinatesAndMasks MethodStatic
create a circular doubly linked list of internal and external nodes from polygon points.
- Optionally jump to the "other" side so the returned loop has positive area
createFaceLoopFromCoordinatesAndMasks(graph: , data: LineStringDataVariant, returnPositiveAreaLoop: boolean, maskForBothSides: , maskForOtherSide: ): undefined |
Parameter | Type | Description |
---|---|---|
graph | graph to receive the new edges | |
data | LineStringDataVariant | array with x,y coordinates |
returnPositiveAreaLoop | boolean | if false, return an edge proceeding around the loop in the order given. If true, compute the loop area and flip return the side with positive area. |
maskForBothSides | mask to apply on both sides. | |
maskForOtherSide | mask to apply on the "other" side from the returned loop. |
Returns - undefined |
Defined in
- topology/Triangulation.ts Line 409
Last Updated: 20 June, 2023