collectConnectedComponentsWithExteriorParityMasks MethodStatic
Collect arrays gathering faces by connected component.
collectConnectedComponentsWithExteriorParityMasks(graph: , parityEdgeTester: undefined | HalfEdgeTestObject, parityMask: = HalfEdgeMask.NULL_MASK): [][]
Parameter | Type | Description |
---|---|---|
graph | graph to inspect | |
parityEdgeTester | undefined | HalfEdgeTestObject | (optional) function to test if an edge is a parity change (e.g., a boundary edge). |
parityMask | (optional, along with parityEdgeTester) mask to apply indicating parity. If this is Mask.NULL_MASK, there is no record of parity. |
Returns - [][]
Defined in
- topology/HalfEdgeGraphSearch.ts Line 204
Last Updated: 20 June, 2023