mutatePartners MethodStatic
Construct a CurveCollection with the same structure as collectionA and collectionB, with primitives constructed by the caller-supplied primitiveMutator function.
mutatePartners(collectionA: CurveCollection, collectionB: CurveCollection, primitiveMutator: CurvePrimitiveMutator): undefined | CurveCollection
Parameter | Type | Description |
---|---|---|
collectionA | CurveCollection | |
collectionB | CurveCollection | |
primitiveMutator | CurvePrimitiveMutator |
Returns - undefined | CurveCollection
Returns undefined if there is any type mismatch between the two collections.
Defined in
- solid/RuledSweep.ts Line 157
Last Updated: 20 June, 2023