IModelJson.ArcByVectorProps Interface
Interface for Arc3d value defined by center, vectorX, vectorY and sweepStartEnd.
Properties
Name | Type | Description | |
---|---|---|---|
center | XYZProps | Arc center point | |
sweepStartEnd | AngleSweepProps | Start and end angles in parameterization X=C+cos(theta) * vectorX + sin(theta) * vectorY |
|
vectorX | XYZProps | Vector from center to 0-degree point (commonly called major axis vector) | |
vectorY | XYZProps | Vector from center to 90-degree point (common called minor axis vector) |
Defined in
- serialization/IModelJsonSchema.ts Line 223
Last Updated: 20 June, 2023