markPairedEdgesInvisible MethodStatic
- Find mated pairs among facet edges.
- Mated pairs have the same vertex indices appearing in opposite order.
- Mark all non-mated pairs visible.
- At mated pairs
- if angle across the edge is larger than
sharpEdgeAngle
, mark visible - otherwise mark invisible.
- if angle across the edge is larger than
markPairedEdgesInvisible(mesh: IndexedPolyface, sharpEdgeAngle?: Angle): void
Parameter | Type | Description |
---|---|---|
mesh | IndexedPolyface | mesh to be marked |
sharpEdgeAngle | Angle |
Returns - void
Defined in
- polyface/PolyfaceQuery.ts Line 1271
Last Updated: 20 June, 2023