collectEdgesByDihedralAngle MethodStatic
Return manifold edge pairs whose dihedral angle is bounded by the given angle.
- The dihedral angle of a manifold edge is measured between the normals of its two adjacent faces.
- Boundary edges are not returned as they are not manifold.
collectEdgesByDihedralAngle(mesh: Polyface | PolyfaceVisitor, maxSmoothEdgeAngle?: Angle, sharpEdges: boolean = false): SortableEdgeCluster[]
Parameter | Type | Description |
---|---|---|
mesh | Polyface | PolyfaceVisitor | existing polyface or visitor |
maxSmoothEdgeAngle | Angle | maximum dihedral angle of a smooth edge. If undefined, uses Geometry.smallAngleRadians . |
sharpEdges | boolean | true to reverse the angle threshold test and return sharp edges; otherwise return smooth edges (default) |
Returns - SortableEdgeCluster[]
Defined in
- polyface/PolyfaceQuery.ts Line 1230
Last Updated: 20 June, 2023