clipPolyfaceInsideOutside MethodStatic
Clip each facet of polyface to the ClipPlane or ConvexClipPlaneSet
- accumulate inside and outside facets -- to destination.builderA and destination.builderB
- if
destination.buildClosureFaces
is set, and also build closure facets - This method parses the variant input types and calls a more specific method.
- WARNING: The new mesh is "points only".
- outputSelect applies only for UnionOfConvexClipPlaneSets -- see PolyfaceClip.clipPolyfaceUnionOfConvexClipPlaneSetsToBuilders
clipPolyfaceInsideOutside(polyface: Polyface, clipper: ConvexClipPlaneSet | ClipPlane | UnionOfConvexClipPlaneSets, destination: ClippedPolyfaceBuilders, outputSelect: number = 0): void
Parameter | Type | Description |
---|---|---|
polyface | Polyface | |
clipper | ConvexClipPlaneSet | ClipPlane | UnionOfConvexClipPlaneSets | |
destination | ClippedPolyfaceBuilders | |
outputSelect | number |
Returns - void
Defined in
- polyface/PolyfaceClip.ts Line 442
Last Updated: 20 June, 2023