findOrAddPointInLineString Method
Announce point coordinates. The implementation is free to either create a new point or (if known) return index of a prior point with the same coordinates.
findOrAddPointInLineString(ls: LineString3d, index: number, transform?: Transform, priorIndex?: number): undefined | number
Parameter | Type | Description |
---|---|---|
ls | LineString3d | |
index | number | Index of the point in the linestring. |
transform | Transform | |
priorIndex | number |
Returns - undefined | number
Returns the point index in the Polyface.
Defined in
- polyface/PolyfaceBuilder.ts Line 364
Last Updated: 20 June, 2023