addTrianglesInUncheckedConvexPolygon Method
Add triangles from points[0] to each far edge
- Assume the polygon is convex.
- i.e. simple triangulation from point0
- i.e. simple cross products give a good normal.
addTrianglesInUncheckedConvexPolygon(ls: LineString3d, toggle: boolean): void
Parameter | Type | Description |
---|---|---|
ls | LineString3d | linestring with point coordinates |
toggle | boolean |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 283
Last Updated: 20 June, 2023