addSweptIndexedPolyface Method
Add facets from the source polyface, from its translation along the vector, and from its swept boundary edges, to form a polyface that encloses a volume.
addSweptIndexedPolyface(source: IndexedPolyface, sweepVector: Vector3d, triangulateSides: boolean = false): boolean
Parameter | Type | Description |
---|---|---|
source | IndexedPolyface | the surface mesh to sweep |
sweepVector | Vector3d | the direction and length to sweep the surface mesh |
triangulateSides | boolean | whether to triangulate side facets, or leave as quads |
Returns - boolean
whether the added facets comprise a simple sweep. If false, the resulting mesh may have self-intersections, be non-manifold, have inconsistently oriented facets, etc.
Defined in
- polyface/PolyfaceBuilder.ts Line 1913
Last Updated: 20 June, 2023