addBetweenLineStringsWithRuleEdgeNormals Method
Add facets between lineStrings with matched point counts.
- surface normals are computed from (a) curve tangents in the linestrings and (b)rule line between linestrings.
- Facets are announced to addIndexedQuad.
- addIndexedQuad is free to apply reversal or triangulation options.
addBetweenLineStringsWithRuleEdgeNormals(lineStringA: LineString3d, vA: number, lineStringB: LineString3d, vB: number, addClosure: boolean = false): void
Parameter | Type | Description |
---|---|---|
lineStringA | LineString3d | |
vA | number | |
lineStringB | LineString3d | |
vB | number | |
addClosure | boolean |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 822
Last Updated: 20 June, 2023