terminateFacet Method
announce the end of construction of a facet.
- The "open" facet is checked for:
** Same number of indices among all active index arrays -- point, normal, param, color ** All indices are within bounds of the respective data arrays.
- in error cases, all index arrays are trimmed back to the size when previous facet was terminated.
- "undefined" return is normal. Any other return is a description of an error.
terminateFacet(validateAllIndices: boolean = true): any
Parameter | Type | Description |
---|---|---|
validateAllIndices | boolean |
Returns - any
Defined in
- polyface/Polyface.ts Line 430
Last Updated: 20 June, 2023