constructor MethodProtected
Constructor for a new polyface.
IndexedPolyface(data: PolyfaceData, facetStart?: number[], facetToFaceData?: number[]): IndexedPolyface
Parameter | Type | Description |
---|---|---|
data | PolyfaceData | PolyfaceData arrays to capture. |
facetStart | number[] | optional array of facet start indices (e.g. known during clone) |
facetToFaceData | number[] |
Returns - IndexedPolyface
Defined in
- polyface/Polyface.ts Line 169
Last Updated: 20 June, 2023