addIndexedPolyface Method
- Add facets from source to this polyface.
- Optionally reverse facet indices as per PolyfaceData.reverseIndicesSingleFacet() with preserveStart = false, and invert source normals.
- Optionally apply a transform to points and normals.
- Will only copy param, normal, color, and face data if we are already tracking them AND/OR the source contains them.
addIndexedPolyface(source: IndexedPolyface, reversed: boolean, transform: undefined | Transform): void
Parameter | Type | Description |
---|---|---|
source | IndexedPolyface | |
reversed | boolean | |
transform | undefined | Transform |
Returns - void
Defined in
- polyface/Polyface.ts Line 188
Last Updated: 20 June, 2023