sortAndCollectClusters Method
sort the edges, and look for three categories of paired edges:
- caller must allocate all result arrays of interest.
- Any combination of the result arrays may be
undefined
, indicating that category is to be ignored. - Any combination of the result arrays may be aliased as the same target, in which case those to categories are merged into the target.
- For instance, to ignore manifold pairs and collect all others (singleton, null, and other) as a single array
allOther
, createconst allOther = []
as an empty array and callsortAndCollectClusters (undefined, allOther, allOther, allOther);
sortAndCollectClusters(manifoldPairs: undefined | SortableEdgeCluster[], singletons?: SortableEdgeCluster[], nullEdges?: SortableEdgeCluster[], allOtherClusters?: SortableEdgeCluster[]): void
Parameter | Type | Description |
---|---|---|
manifoldPairs | undefined | SortableEdgeCluster[] | optional array to receive pairs of properly mated SortableEdgePairs, i.e. simple interior edges adjacent to two facets in opposing directions. |
singletons | SortableEdgeCluster[] | optional array to receive edges that are simple boundary edges. |
nullEdges | SortableEdgeCluster[] | optional array to receive arrays of null edges (same start and end vertex) |
allOtherClusters | SortableEdgeCluster[] | optional array to receive arrays in which all the edges are partners in an undirected sense but not a simple directed pair. |
Returns - void
Defined in
- polyface/IndexedEdgeMatcher.ts Line 160
Last Updated: 20 June, 2023