getColor Method
Get color interpolated from facet data.
getColor(facetColors?: number[], facetVertices?: IndexedXYZCollection, distanceTolerance: number = Geometry.smallMetricDistance): undefined | number
Parameter | Type | Description |
---|---|---|
facetColors | number[] | used to compute the color cache |
facetVertices | IndexedXYZCollection | used to compute the barycentric coordinate cache |
distanceTolerance | number | used to compute the barycentric coordinate cache |
Returns - undefined | number
cached color
Defined in
- polyface/FacetLocationDetail.ts Line 430
Last Updated: 20 June, 2023