lineSegment2dXYTransverseIntersectionUnbounded MethodStatic
Return true if lines (a0,a1) to (b0, b1) have a simple intersection. Return the fractional (not xy) coordinates in result.x, result.y
lineSegment2dXYTransverseIntersectionUnbounded(a0: Point2d, a1: Point2d, b0: Point2d, b1: Point2d, result: Vector2d): boolean
Parameter | Type | Description |
---|---|---|
a0 | Point2d | start point of line a |
a1 | Point2d | end point of line a |
b0 | Point2d | start point of line b |
b1 | Point2d | end point of line b |
result | Vector2d | point to receive fractional coordinates of intersection. result.x is fraction on line a. result.y is fraction on line b. |
Returns - boolean
Defined in
- numerics/Polynomials.ts Line 1391
Last Updated: 20 June, 2023