normalizeWeight Method
If this.w
is nonzero, return a 4d point (x/w,y/w,z/w, 1)
If this.w
is zero, return undefined.
normalizeWeight(result?: Point4d): undefined | Point4d
Parameter | Type | Description |
---|---|---|
result | Point4d | optional result |
Returns - undefined | Point4d
Defined in
- geometry4d/Point4d.ts Line 369
Last Updated: 20 June, 2023