createFromPoint MethodStatic
Create a Point4d
from
- Point2d, Point3d, or Point4d
- other structure with members x,y and optional z,w
- array of numbers
- default z is 0.0
- default 2 is 1.0 (array[3] can replace)
createFromPoint(point: number[] | Point4d | Readonly<WritableXAndY> | Readonly<WritableXYAndZ>): Point4d
Parameter | Type | Description |
---|---|---|
point | number[] | Point4d | Readonly<WritableXAndY> | Readonly<WritableXYAndZ> |
Returns - Point4d
Defined in
- geometry4d/Point4d.ts Line 235
Last Updated: 20 June, 2023