collectChains MethodStatic
- Restructure curve fragments as chains
- Return the chains, possibly wrapped in BagOfCurves if there multiple chains.
collectChains(fragments: GeometryQuery[], gapTolerance: number = Geometry.smallMetricDistance): ChainTypes
Parameter | Type | Description |
---|---|---|
fragments | GeometryQuery[] | fragments to be chained |
gapTolerance | number |
Returns - ChainTypes
Defined in
- curve/RegionOps.ts Line 457
Last Updated: 20 June, 2023