cloneCurvesWithXYSplitFlags MethodStatic
- Find all intersections among curves in
curvesToCut
andcutterCurves
- Return fragments of
curvesToCut
. - For a
Loop
,ParityRegion
, orUnionRegion
incurvesToCut
- if it is never cut by any
cutter
curve, it will be left unchanged. - if cut, the input is downgraded to a set of
Path
curves joining at the cut points.
- if it is never cut by any
- All cutting is "as viewed in the xy plane"
cloneCurvesWithXYSplitFlags(curvesToCut: undefined | CurvePrimitive | CurveCollection, cutterCurves: CurveCollection): undefined | CurvePrimitive | CurveCollection
Parameter | Type | Description |
---|---|---|
curvesToCut | undefined | CurvePrimitive | CurveCollection | |
cutterCurves | CurveCollection |
Returns - undefined | CurvePrimitive | CurveCollection
Defined in
- curve/RegionOps.ts Line 417
Last Updated: 20 June, 2023