segmentIndexAndLocalFractionToGlobalFraction Method
Convert a segment index and local fraction to a global fraction.
segmentIndexAndLocalFractionToGlobalFraction(index: number, localFraction: number): number
Parameter | Type | Description |
---|---|---|
index | number | index of segment being evaluated |
localFraction | number | local fraction in [0,1] within the segment |
Returns - number
global fraction f in [0,1] such that the segment is parameterized by index/N <= f <= (index+1)/N.
Defined in
- curve/LineString3d.ts Line 580
Last Updated: 20 June, 2023