quickUnitNormal Method
compute and normalize cross product among 3 points on the linestring.
- "any" 3 points are acceptable -- no test for positive overall sense.
- This is appropriate for polygon known to be convex.
- use points spread at index step n/3, hopefully avoiding colinear points.
- If that fails, try points 012
quickUnitNormal(result?: Vector3d): undefined | Vector3d
Parameter | Type | Description |
---|---|---|
result | Vector3d | computed normal. |
Returns - undefined | Vector3d
Defined in
- curve/LineString3d.ts Line 827
Last Updated: 20 June, 2023